基地

去往未知,而不是未来。

使用 apt-get install golang 安装的 go 语言版本过低,只有1.6.2。只能手动下载安装新版本。

Go 语言 1.6 之后的版本,先从项目的 vendor 目录中查找依赖,如果找不到,再去 GOPATH 和 GOROOT 中查找。

一般来说,不要提交 vendor 到代码仓库中。

参考:https://studygolang.com/articles/15172

在本地编译 GoLang 语言的程序需要有 go 环境。这里记录了怎么安装 go 环境。